Maquina Virtual con Asterisk 13 y Freepbx

Hol@ a todos despues del post anterior he decidido ponerlo mas fácil y para que no os tengáis que complicaros dejo una máquina ya montada y funcional para que la despleguemos en vuestros ESX, Vcenters o Workstations.

Tan solo teneis que importar la maquina , la contraseña de root como la de mysql es caracol

La podeis descargar de aqui

Soporte codec g729 g723 Asterisk13

Continuando en la linea de los post anteriores hoy vamos a agregar la versión free de estos codecs para usarlos por ejemplo con el proveedor vozelia.

Veréis que son muy faciles de instalar

Los binarios de los codecs los podeis descargar aqui 

Seleccionamos el binarios para vuestra distribución y tipo de procesador en mi caso he seleccionado el ficheros codec_g729-ast130-gcc4-glibc-core2.so  y  codec_g723-ast130-gcc4-glibc-core2.so que corresponden a los codecs g729 y g723 para los procesadores cores2

Los descargamos al directorio modules de nuestro asterisk y los renombramos

cd /usr/lib/asterisk/modules
wget  http://asterisk.hosting.lv/bin/codec_g729-ast130-gcc4-glibc-core2.so
mv codec_g729-ast130-gcc4-glibc-core2.so codec_g729.so
wget  http://asterisk.hosting.lv/bin/codec_g723-ast130-gcc4-glibc-core2.so
mv codec_g723-ast130-gcc4-glibc-core2.so codec_g723.so
chown asterisk:asterisk codec_g729.so
chmod 755 codec_g729.so
chown asterisk:asterisk codec_g723.so
chmod 755 codec_g723.so

Reiniciamos asterisk y entramos en el CLI para que nos muestre la tabla de transcoding

asterisk -r
core show translations
[/core]
 

 

Instalacion de Asterisk13 y FreePbx en Debian 8.3

Aquí os dejo un pequeño post con los pasos a seguir para la instalación de un sistema Asterisk + FreePbx

Partimos de un sistema recién instalado con Debian 8.3 con el sistema base sin interfaz gráfico y con el servicio de SSH activo.

Modificamos el archivo de configuración para poder conectarse como root


sed -i 's/PermitRootLogin without-password/PermitRootLogin yes/' /etc/ssh/sshd_config
service sshd restart

Link al Post para modificarlo manualmente Sigue leyendo Instalacion de Asterisk13 y FreePbx en Debian 8.3

Una nueva forma de renovar tus equipos

AAA-Group compra y vende equipos informáticos de segunda mano

image1

¿Tienes algún router que ya no usas? ¿Buscas una opción más económica para poder hacer tests de preproducción o de redundancia? En la actualidad, existen alternativas para no tener que comprar un router nuevo, especialmente en entornos no críticos, pero incluso para los entornos críticos siempre y cuando se pretendan utilizar marcas de confianza como Cisco.

Quizás también tenéis algo en el almacén o en el data-centre acumulando polvo…Pues para estos casos, AAA Group, una empresa con sede en Barcelona, se dedica a recomprar equipos y routers de networking, servidores, etc, de marcas reconocidas como Cisco, HP, IBM, DELL, etc…

Podéis encontrar su web aquí, y si preferís una atención personalizada, llamad directamente a sus oficinas al 935 305 503.

Actualizar Esxi 6.0 desde SSH

Hoy explicaremos como actualizar un servidor Esxi 6.0 desde la consola de comandos SSH , con este procedimiento podremos actualizar nuestro ESXi con los nuevos Kb’s de VMWARE o hacer un update completo de version como por ejemplo de ESXi 5.5 a ESXi 6.0
1. Descargamos el ficheros de actualizacion de la pagina de: https://my.vmware.com/group/vmware/patch

Esxi6-Update

 

2. Lo subimos al datastore del Host que queremos actualizar

3. Nos conectamos mediante SSH al HOST a actualizar

4.Apagamos o movemos la maquinas virtuales que tengamos en ese host, y lo ponemos en modo mantenimiento

Ejecutamos el siguiente comando :

vim-cmd hostsvc/maintenance_mode_enter
esxcli software vib update -d /vmfs/volumes/Local/ESXi600-201504001.zip

*Nota: /vmfs/volumes/Local/ es la ruta donde anteriormente hemos subido el fichero de actualización

Update-Esxi6Veremos como se actualiza el sistema , cuando este proceso termine reiniciamos el HOST y ya lo tendremos actualizado

5. Ahora toca sacar el host del modo mantenimiento, lo haremos con el siguiente comando

vim-cmd hostsvc/maintenance_mode_exit

Preparando Debian Jessie como home server Post 1

Despues de instalar las opciones por defecto procedemos a instalar el servicio de ssh

apt-get install ssh

por defecto en debian el acceso a root esta desactivado para evitar esto solo tenemos que comentar una linea en el fechero de configuracion ssh
Editamso el fichero con el siguiente comando

nano /etc/ssh/sshd_config

y comentamos la siguiente linea


# Package generated configuration file
# See the sshd_config(5) manpage for details

# What ports, IPs and protocols we listen for
Port 22
# Use these options to restrict which interfaces/protocols sshd will bind to
#ListenAddress ::
#ListenAddress 0.0.0.0
Protocol 2
# HostKeys for protocol version 2
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key
HostKey /etc/ssh/ssh_host_ecdsa_key
HostKey /etc/ssh/ssh_host_ed25519_key
#Privilege Separation is turned on for security
UsePrivilegeSeparation yes

# Lifetime and size of ephemeral version 1 server key
KeyRegenerationInterval 3600
ServerKeyBits 1024

# Logging
SyslogFacility AUTH
LogLevel INFO

# Authentication:
LoginGraceTime 120
#PermitRootLogin without-password
StrictModes yes

RSAAuthentication yes
PubkeyAuthentication yes
#AuthorizedKeysFile %h/.ssh/authorized_keys

Despues de modificar el parametro reinicimos el servicio para que cargue los cambios

servide sshd restart

DRD4

Hoy solo quiero dejaros una pequeña lectura con la que me siento muy identificado.

 

http://www.uned.es/psico-1-fundamentos-biologicos-conducta-I/tablon/articulos/04_gen_riesgo.htm

Como enviar los logs de MikrotiK

Siendo 192.168.19.11 nuestro servidor syslos estos son los comandos que tenemos que pegar en la consola de mikrotik para poder enviar los logs a este server.

/system logging action
set remote bsd-syslog=yes name=remote remote=192.168.19.11 remote-port=514 src-address=0.0.0.0 syslog-facility=local0 syslog-severity=auto target=remote
/system logging
add action=remote disabled=no prefix="" topics=!async